Erratum PCIE-65 patches no longer compile / apply with current Linux kernels

With so many of you patching your kernel to allow AMD or Intel GPU’s to run, did nobody notice the erratum PCIE-65 patches need updating? They no longer compile on 6.9.0 and do not apply on 6.10-rc1

See Issues · AmpereComputing/linux-ampere-altra-erratum-pcie-65 · GitHub

AND AS A REMINDER, NO WARRANTIES OR SUPPORT IS PROVIDED.

Looks like you are on your own.

No warranties or support in the formal sense. But we are not on our own here.

3 Likes

The patches have just been fixed in the Github repository.
They have been fixed in such a way, that they now apply and compile on kernel 6.9 and 6.10-rc1, yet still apply and compile on kernels 6.7 and 6.8.
Great work!

1 Like