Lm-sensors support for ASRock Rack TR1 connector

I have connected this temperature sensor to the TR1 connector on the the altrad8ud-1l2t motherboard.

It appears to work, the BMC recognizes it and lists the temperature. But the OS (Fedora 40) is not listing the temperature through lm-sensors. Unlike the SoC temperature, which is listed as “apm_xgene”.

What would it take to pass this data to lm-sensors? I tried sensors-detect but that did not help.

lm-sensors support would allow me to use the water temperature in the fan management software I am using.

1 Like

I have tried different settings, software to show readings from fans and so far nothing works.
BMC can see readings, but nothing else, including BIOS 2.06. In previous BIOS I could see readings. Maybe we should report the bug to AsrockRack.

Previous BIOS or previous BMC? Maybe it worked in the proprietary BMC that came before OpenBMC. My system came with OpenBMC factory installed.

OpenBMC is preinstalled too, but I have not used it as I am not interested in server like access. I will rather work with display via VGA and/or NVidia GPU or maybe RDP/VNC.
Readings were displayed in BIOS in previous version. Now it shows zeros in readings.