Anyone familiar with Oracle Cloud Free Tier?

Hi there! :wave:

Until last Monday, I utilized a VM in the Oracle Cloud Free Tier (based on an Ampere CPU). Unfortunately, due to a PC crash, I lost the key required to access this machine.

In an attempt to recreate a new VM accessible from my temporary laptop, I terminated the existing one. However, I encountered an issue:

Out of capacity for shape VM.Standard.A1.Flex in availability domain AD-1.

Naively, I assumed I could recreate the same VM since I had terminated it. :man_shrugging: Clearly, I was mistaken. Is there a workaround or trick to achieve this?

Thanks!

I think that it means that there are no available free instances available at that region. There are certain regions that are rather busy and/or have limited availability. I know for me, I tried San Jose, but that never worked. I switched to Montreal and it has always seemed to work. Now to do this, I had to create a new account, since I couldn’t change regions.

For more detail try this article: Reddit - Dive into anything

This is always something that I wanted to crowd source, what Oracle regions work the best? But that might be like asking a surfer where their best secret spot is.

Anyone have any better ideas?

1 Like

First, there are ways to recover from loosing a key;

  1. Boot on the console, and in recovery boot manually put in a new key
  2. mount the boot disks on another VM, and rekey

As far as the issues with resources, with OCI growing quickly ( I talk to customers every week that ar moving to OCI for price and performance) , is resources are not always there. usually unless in a pinch, you can just wait a week or two.

It’s not just the free tier for Ampere, seen availability issues with the paid instances as well. Hopefully Oracle will be getting in more servers soon.

Given your problem I would have tried #1 1st.

Erik

2 Likes

Thank you, folks! :+1:

I spent a few hours playing in the console, but with no luck.
If I had known earlier that I wouldn’t be able to recreate a VM, I would have asked for help to get my new keys working. :blush:
It seems my deleted VM must have brought joy to somebody else. :man_shrugging: I’ll keep trying every day until it works.