Mt. Jade Fans Running 100%

I’ve got my hands on some second-had Wiwynn SV328R servers that I’m trying to make operational. I’ve installed Ubuntu Server 22.04.3, but cannot seem to be able to get the fans to run at anything less that 100%. Any insights as to where I might find the IPMITool raw commands for this machine would be appreciated.

Update:I found some info in the Mt. Jade docs online indicating that the 2S1P (2 Socket/1 Processor) configuration will run the fans 100%. A solution might be to upgrade the firmware and see if I can add another processor to make it a 2S2P. Curious to see if this is possible or if Socket 1 is hardware disabled. Anyone know where I can get the latest AMI firmware?

Oh my, I have been through this…

For me, the issue was the use of a NVMe drive model that was not on the Hardware Compatibility List… If you are running NVMe drives, try pulling them and powering on - obviously the machine won’t boot, but the fans should not go into hovercraft mode.

I have run both 2S1P and 2S2P with auto fan control, don’t know where you saw that 2S1P will run at 100% fan speed.

For a temporary workaround (with some problems/risk), you can set the fan speeds manually, but then it is on you if the processors overheat due to high load.

PERFORM AT YOUR OWN RISK

To disable auto fan speed setting:
ipmitool -I lanplus -H <raw IP, eg 192.168.1.XXX> -U username -P password raw 0x3c 0x03 0x01
Note the username and password are for the BMC login.

Then for each fan:
ipmitool -I lanplus -H raw_IP -U username -P password raw 0x3c 0x04 <fan number, eg 0x01> <rpm percentage, eg 0x19 for 25% speed>

The number of chassis fans varies by model… mine had 8. I highly suggest that if it is in fact unsupported drives, you replace them and go back to auto fan control.

To go back to auto fan control:
ipmitool -I lanplus -H raw_ip -U username -P password raw 0x3c 0x03 0x00

2 Likes

Hi, looks like you found the Getting Started Guide:

Appendix E confirms what you found.

The firmware is generally autodetecting of 1P or 2P but the fan 100% looks like it’s a “feature” of the Wiwynn board. It’s a registered desgin with OCP at https://www.opencompute.org/documents/open-compute-specification-mt-jade-rev-1-0-pdf-1

The UEFI BIOS for 1P and 2P Jade is in the file titled: Ampere SRP 2.10d.20230530 AptioV Binary Package available on the Ampere Customer Connect portal. You’ll need to register and sign an NDA for access.

Alternatively for the US, Phoenics would be the right people to call for a second processor…
https://phoenicselectronics.com/manufacturers/ampere/

Good to know I’m not alone. Thanks for the info on the raw codes. I’ll have to look up the HCL for acceptable NVMe drives.

Thanks for the pointer to the Binary Package. I’m hoping upgrading the firmware will fix whatever is going on with detecting the 2nd processor - the current firmware is pretty old.

1 Like

Current firmware last release is 30th May '23. - In SRP Software Release Package 2.10d.

I have a script for raw setting on my Mt Snow (differing raw codes for fans).

# Script to control the fans on Mt. Snow
# DON’T FORGET TO ENABLE AUTO MODE BEFORE RUNNING A WORKLOAD
#!/bin/bash
 
if [  $# -ne 1 ]; then
        echo "usage: ./setfans-snow.sh <0-100|auto>"
        exit 1
fi
 
if [ $1 = "auto" ];
then
 echo "Setting fans to auto"
 ipmitool -I lanplus -H <IP addr> -U <admin> -P <password> raw \
 0x2e 0x10 0x0a 0x3c 0 64 0 0 0 \
 > /dev/null 2>&1
else
  for ((i=0;i<=6; i++));
  do
    printf "Setting fan %d to %d%%\n" $i $1
    ipmitool -I lanplus -H <IP addr> -U <admin> -P <password> raw \
    0x2e 0x10 0x0a 0x3c 0 64 1 $1 $i \
    > /dev/null 2>&1
  done
fi