OSes for Ampere Developer Platform or Dev Kit (Linux / Windows)

So… mostly asking for those who have already done some experimenting.

I know the Development Platform comes preloaded with Ubuntu 20.04, but it seems 22.04 already supports Ampere pretty well too. Is there any reason to hold off moving to 22.04?

Also, I saw some Twitter activity around Windows on Ampere—but it looks like to get Windows 11 for ARM you have to jump through some hoops (including building yourself an ISO using something like https://uupdump.net and doing so on a Windows machine already!). I tried downloading a Windows 11 for ARM insider build but that resulted in an ‘Error’ from Microsoft (I am an Insider, though my membership is pretty old at this point, maybe I’m expired?).

Finally, any other Linux distros that are more or less ‘tier 1’ instead of just “it works, but nobody’s really testing it”?


I am running Fedora 38 Workstation on mine. It works well. Though videocard compatability is tricky.

1 Like

Thanks for the information.
Do you know if there is a compatibility array somewhere?

I would say that any distribution built with not ancient kernel (5.10+?) should work if the proper kernel options are enabled.

Ampere systems are not SBC to require own kernels, device trees and other weird tweaks and hacks.

I would expect Debian, Fedora, RHEL to run out of the box (I do not track other ones).

1 Like

Maybe even Armbian UEFI… who knows. :blush:

Armbian is a distro for those SBC which cannot run Debian.

If you have Arm system which runs Debian then why bother playing with Armbian?

I’m not so sure about your definition, but I get what you mean.
It would be difficult for me to give the definition of Armbian too…
For me, it’s not an OS, it provides OS (Debian and Ubuntu) for SBCs, laptops, thanks to the use of a build script.
So in the end, you have a Ubuntu or Debian image built by Armbian, with a few built-in tools that make my life easier.
So when I say “my device runs Armbian”, I’m wrong, plenty wrong.

But you’re right, it does not make much sense using Armbian on something that would run Debian out of the box, unless Armbian allows you to feel “at home” on any device (which it does for me, even on RISC-V machines). :person_shrugging:

I don’t own (yet?) a Developer Platform or Dev Kit, so better remove my Armbian fanboy cape and let the grown ups continue discussing valid OS choices for these beautiful machines. :heart_eyes:

I have nothing against Armbian. It exists to help getting something useful to run on those Shitty Board Craps which are made by vendors who do not care about about getting them supported in mainline U-Boot/kernel/etc.

For me “Debian based rootfs with custom kernel and some extra packages” is not Debian. It is Debian based something, fork, remix, etc.

When I buy Arm hardware (for development) I check how it is supported. When it comes to AArch64 I owned:

  • Pine A64 2GB (Kickstarter edition, bought as an experiment)
  • Raspberry/Pi 3 (ordered on announcement day to see how they did things, sold few months later)
  • Pine RockPro64 (to check how SBC look “nowadays”, helped improving it’s config in mainline u-boot, did some distro testing/enablement)
  • EspressoBin (bought from friend, used as a router (OpenWRT) for some time)
  • Honeycomb (got free, paid customs, used as a development/testing box)

Also had APM Mustang (great SBSA/SBBR machine years ago). Now I use Macbook 14" with M1Pro as my development system (running Fedora Asahi Remix). Both machines are work related.

1 Like

Nice combination you have there (M1Pro running Fedora). :+1:

1 Like

comhpc-docs – I-Pi SMARC is the only list I know of. I believe the Radeon 7900 range should also work, I have not been willing to spend $800 to find out


I’d done a bit of suck it and see testing on live distros last year, here’s my findings:

Live Boot distros that worked:


kali-linux-2022-W32-live-arm64.iso - boots via BMC Remote Console media attach.

https://sourceforge.net/p/clonezilla/discussion/Open_discussion/thread/8c1e35aa/- req for Arm image
Clonezilla / Discussion / Clonezilla live: Clone ARM systems - Is it possible? more discussion, working on rock64
Index of /clonezilla-live/experimental/arm
Index of /clonezilla-live/experimental/arm/2.6.6-11 --ISOs
clonezilla-live-2.6.6-11-arm64.iso - boots via BMC Remote Console media attach.
2020-03-13-clonezilla-live-2.6.6-3-arm64-preview-bpi-m64-sd-emmc.img – untried but should work.


https://github.com/finnix/finnix-live-build- Arm64?
https://snapshots.finnix.org/ci/finnix-live-build-arm64-artifacts/- unofficial live build
finnix-arm64.hybrid.iso - boots via BMC Remote Console media attach.

Not tried yet.

Test for Ventoy Arm64UEFI boot

Can’t use these yet :-
Rescuezilla Arm build
Issues · rescuezilla/rescuezilla · GitHub call for official build
Issues · rescuezilla/rescuezilla · GitHub promise to make build
Ultimate Boot CD - no UEFI support.
https://www.system-rescue.org- no Arm build
http://www.mondorescue.org- no Arm build
Knoppix no Arm build
Puppy Linux - only Pi builds at 32bit.

An impromptu pxe into the netboot.xyz menu. netboot/pixiecore at main · danderson/netboot · GitHub

1 Like

OSes are an issue for me as well with my Lenovo C630.

Lenovo provides a tool which will allow you to build an Win10 ARM image on a Win10 x86_64 machine. It’s painful, and then eventually I was forcibly upgraded to Win11.

I tried looking for Win11 ARM images, but nothing I found worked. There were a lot of sketchy websites out there, and the official Windows ISO situation leaves a lot to be desired. I mean I would pay for an ISO, but there’s just no reasonable path that works.

If you find a workable path, please let us know!!

I’ve been trying to get Windows 11 going on my Developer Platform workstation, but no luck so far: Ampere Altra Developer Platform · Issue #19 · geerlingguy/sbc-reviews · GitHub

1 Like

Alessandro and the folks over at https://cloudbase.it/ had Win 11 running on Mt Jade (2P 2u) a while back. I could see if they want to drop some advice on this Discourse.

@Aaron do you know who in the engineering team had worked on Windows 10/11 boot?

1 Like

That would be great! I’ve finally gotten a download of the VMDK from a friend, converted that to .raw format, wrote to NVMe using dd, and… I get the BSOD with an ACPI_BIOS_ERROR

1 Like

Sounds like you’re using something similar to Adrian’s method:

I’ll give them a shout.

Yeah, that’s the article I found that had the most detail — though his BIOS seems vastly different than the one that ships with the ADLINK system (his BIOS even had settings for how the CPU core distributes workloads).

Not off hand, but I will ask…

1 Like

@avladu any idea on this?

1 Like

Hello, glad to help. I have recently seen that you can easily download a VHDX from the oficial website here https://www.microsoft.com/en-us/software-download/windowsinsiderpreviewARM64 if you are a Windows insider (just downloaded today a Windows11_InsiderPreview_Client_ARM64_en-us_25324.VHDX).

Then, you can use qemu-img (.exe is available too here qemu-img for WIndows - Cloudbase Solutions) to convert it to a raw file, then you can dd it either via an smb share, an usb stick or even via curl | tar if you have an apache2/nginx around and a live Ubuntu 22.04 running on the box, to the disk of your choice.

These are ballpark instructions, please let me know if you need anything or you have an issue with the above workflow.